DepressionChurch-EclipseLevelInCharacterSelection icon

EclipseLevelInCharacterSelection

Add highest reached Eclipse level in Character Selection Screen

Last updated a month ago
Total downloads 2441
Total rating 0 
Categories Survivors of the Void Client-side
Dependency string DepressionChurch-EclipseLevelInCharacterSelection-1.1.3
Dependants 2 other mods depend on this mod

This mod requires the following mods to function

bbepis-BepInExPack-5.4.9 icon
bbepis-BepInExPack

Unified BepInEx all-in-one modding pack - plugin framework, detour library

Preferred version: 5.4.9
RiskofThunder-HookGenPatcher-1.2.1 icon
RiskofThunder-HookGenPatcher

MMHOOK generation at runtime.

Preferred version: 1.2.1

README

EclipseLevelInCharacterSelection

Add highest reached Eclipse level in Character Selection Screen

For Modders:

  • THIS IS AWFUL CODE, IF YOU WANT TO LEARN HOW TO WRITE MODS DONT LOOK HERE
  • if you know more about RoR2 Modding and Unity feel free to make a MR/PR and help fix this mess (i really should have worked with assets)

Known Issues:

  • Modded Survivors wont work
  • Ugly Code

Changelog

1.1.3

  • fixed potential null pointer exception (thanks to jasonmarco)

1.1.2

  • Now Client-Side Mod

1.1.1

  • Clean VS Project

1.1.0

  • Fix Void Fiend
  • Even Better Quality

1.0.2

  • Improve Icon Quality

1.0.0

  • Release

Available versions

Please note that the install buttons only work if you have compatible client software installed, such as the Thunderstore Mod Manager. Otherwise use the zip download links instead.

Upload date Version number Downloads Download link  
2022-5-26 1.1.3 1588 Version 1.1.3 Install
2022-4-12 1.1.2 558 Version 1.1.2 Install
2022-4-11 1.1.0 143 Version 1.1.0 Install
2022-4-10 1.0.1 135 Version 1.0.1 Install
2022-4-10 1.0.0 17 Version 1.0.0 Install