Theray070696-ItemTierSelection icon
Last updated a week ago
Total downloads 2343
Total rating 6 
Dependency string Theray070696-ItemTierSelection-2.0.1
Dependants 0 other mods depend on this mod

This mod requires the following mods to function

bbepis-BepInExPack-2.0.0 icon
bbepis-BepInExPack

Unified BepInEx all-in-one modding pack - plugin framework, detour library

Preferred version: 2.0.0
tristanmcpherson-R2API-2.1.16 icon
tristanmcpherson-R2API

A modding API for Risk of Rain 2

Preferred version: 2.1.16
README

Since people in the discord loved the other mod I made, I decided to make a better version.

Discord Screenshot


This mod allows you to set the tier of any item in the game. Want Chronobauble to be a white? Go ahead! Want to make every run a broken run? Set 57 Leaf to tier 1, and have a blast! Think Red Whip shouldn't exist (don't see why, it's the best item in the game Kappa)? Have at it! Want to delete Meteors? Totally understandable!

Only the host requires this mod, and if someone has a different config than the host, it'll still work (person a sets Uke to white, person b sets it to red. Person a hosts, Uke will show up in white shops and printers, but display as a red for person b).

There is one thing that I'll mention here that isn't mentioned in the config. You might notice that boss items are set to 5 by default in the config. This value only works on boss items, and leaves them as boss items. I didn't allow setting normal items to boss items because I don't know how the game will handle it.

The names in the config are probably not familiar, that's because the translation system in RoR2 isn't available when I'm writing the config, so I'm forced to use the internal names. Here's a handy list of the internal names and their respective names

Want to support me modding? Support me on Patreon! https://www.patreon.com/Theray070696


Changelog:

2.0.1
-Fixed equipment being broken.

2.0.0
-Updated for latest RoR2 build (October 10th 2019)

1.1.2
-Fixed dll version being incorrect
-Removed ItemLib incompatibility text from this very file

1.1.1:
-Fixed incompatibility with ItemLib

1.1.0:
-Added support for equipment! All implemented equipment (minus elite equipment) can be disabled, swapped to normal, or swapped to lunar!
-Minor optimization in config loading code (honestly could leave this note out :P)

1.0.0:
-Initial release

Available versions

Please note that the install buttons only work if you have compatible client software installed. Otherwise use the zip download links instead.

Upload date Version number Downloads Download link  
2019-10-11 2.0.1 635 Theray070696-ItemTierSelection-2.0.1.zip Install
2019-10-11 2.0.0 51 Theray070696-ItemTierSelection-2.0.0.zip Install
2019-10-3 1.1.2 733 Theray070696-ItemTierSelection-1.1.2.zip Install
2019-10-1 1.1.1 211 Theray070696-ItemTierSelection-1.1.1.zip Install
2019-9-30 1.1.0 251 Theray070696-ItemTierSelection-1.1.0.zip Install
2019-9-27 1.0.0 462 Theray070696-ItemTierSelection-1.0.0.zip Install