You are viewing a potentially older version of this package. View all versions.
Timberborn_Central-TimberAPI-0.5.3 icon

TimberAPI

Unofficial API to enable easier Timberborn modding

Date uploaded a year ago
Version 0.5.3
Download link Timberborn_Central-TimberAPI-0.5.3.zip
Downloads 18040
Dependency string Timberborn_Central-TimberAPI-0.5.3

This mod requires the following mods to function

BepInEx-BepInExPack_Timberborn-5.4.19 icon
BepInEx-BepInExPack_Timberborn

BepInEx pack for Timberborn. Preconfigured and ready to use.

Preferred version: 5.4.19

README

TimberAPI

Unofficial API to enable easier Timberborn modding

TimberAPI Version Game Version Compatible
0.5.X.X 0.2.8.1
0.4.X 0.2.2.1
0.3.X 0.1.5.2

Currently supported features:

  1. Dependency injection attribute (Configurator)
  2. A comprehensive UI component builder
  3. Universal assetloader, provide your own unity asset bundles
  4. Modify and add specifications to change the game - with just JSON
  5. Full localization support using csv files
  6. Link entities together for data communication
  7. Game version, Api version compatibility check
  8. Mod loader, provides mods to load by a simple json

More Information can be found on the wiki

Timberborn Modding Wiki

TimberAPI Documentation

Documentation for TimberAPI

Provided Sample Plugin with API examples

Example Plugin