gaforb-EruptionUtil icon

EruptionUtil

Adds a new utility for Artificer - Eruption. Completely Configurable, supports Artificer Extended

By gaforb
Last updated 2 weeks ago
Total downloads 7927
Total rating 3 
Categories Mods
Dependency string gaforb-EruptionUtil-2.0.0
Dependants 2 other mods depend on this mod

This mod requires the following mods to function

tristanmcpherson-R2API-3.0.30 icon
tristanmcpherson-R2API

A modding API for Risk of Rain 2

Preferred version: 3.0.30

README

#EruptionUtility This mod adds a new Flame Utility for Artificer - Eruption Blast forward, dealing 360% damage and igniting nearby enemies Config options included for: Initial blast damage, force and proc coeffecient Turning off the blast or burn entirely Adjusting the cooldown and number of stocks Moving the skill to Special Performance option for VFX if you find them too flashy

Known Issues & Compatability

-Supports Artificer Extended's Energetic Resonance passive. -If using Blast Jumper, set the blast force to 0 or you bounce weirdly -ArtiSkillSwap makes flamethrower work with sprinting for letting this skill force sprint.

Future Plans (maybe)

-A two-stage charge up that makes the explosion stronger -More differences between the grounded and aerial versions

Credits

Thanks to LordOfTheNugget for ArtificerFrostSurge and DuckDuckGreyDuck for ArtificerExtended, upon which much of the code for this mod is based. Additional thanks to Rein for some of the code that makes artificer not look stiff while whooshing

Installation

Place EruptionUtility.dll in /Risk of Rain 2/BepInEx/plugins/ Or just use a mod manager. In fact, I recommend that.

Changelog

0.1.0 -Inital beta release with dependency

1.0.0 -Removed ArtificerExtended Dependency -Added config options -Damage and radius slightly increased -Better compatibility with Flamethrower

1.0.1 -Removed blast force for compatibility with Plasmacore's Blast_Jumper

2.0.0 -Added loads of config -Overhauled VFX and added performance option -Tweaked cooldown settings -Restored blast force - now configurable

Available versions

Please note that the install buttons only work if you have compatible client software installed, such as the Thunderstore Mod Manager. Otherwise use the zip download links instead.

Upload date Version number Downloads Download link  
2021-9-4 2.0.0 2866 Version 2.0.0 Install
2021-5-2 1.0.1 3829 Version 1.0.1 Install
2021-4-26 1.0.0 1022 Version 1.0.0 Install
2021-4-26 0.1.0 210 Version 0.1.0 Install